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iGrafx® FlowCharter™ Product Comparison 
 

 
 
Use this worksheet to compare the extensive capabilities of iGrafx with another process mapping product (the “Challenger” tool). Talk to your 
iGrafx account manager if you have additional questions about iGrafx or the product you’re comparing. 
  
 
Key Issue Comparison    (what to look for in a process mapping tool) 
 
 
Swimlane (process functional role) modeling.  Are swimlanes intelligent (e.g. grow and shrink as shapes are added to them) or dumb (e.g. no 
repeating headers on multi-page diagrams)? 
 
Large diagram capabilities.  Are automatic off-page connectors available? Can the tool create a hierarchical process within a single file? Is it easy to 
convert a multi-page diagram to a single page for printing to a plotter?  
 
Editing functions. Do lines drawn from decision shapes automatically include “Yes” / ”No” path text? Do connection lines heal themselves when shapes 
are removed from the connectivity? 
 
Cause & Effect diagramming. How easily can Cause & Effect diagrams be created? Is there a tool that automatically links modeling data, fishbone 
diagram and Pareto Chart together? When lines are lengthened on a fishbone diagram, do other lines retain their original angle to the spine of the 
diagram?  
  
Process modeling. Is information about activity duration times, resource allocations, schedules, transaction rates, etc. included in the process map? 
 
Publishing. Can multi-page diagrams be published in paginated format to Web, Microsoft® Word or PowerPoint® with a single command? Are there 
tools for publishing multiple files at once? 
  
Process analysis and simulation. Are process maps ready for process improvement and optimization using “what-if?” analysis and simulation? 
 
Repository support. Does the tool operate in a collaborative, client / server environment with versioning, audit trail, link management, web viewing and 
access control features?     
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Process Mapping Comparison 
 

Question iGrafx Response Questions for Challenger  

Can swimlanes be defined which grow 
and shrink automatically as shapes are 
inserted? 

Yes. 
Swimlanes adjust when adding or deleting shapes. 
 

Create a page with 5 lanes. 
Add a new page with the same 
lanes. Adjust the size of a lane. 
Is the corresponding swimlane 
on the other page adjusted 
also? 
 

Can swimlanes be added easily to the 
middle of a process map? 

Yes. 
Select an existing swimlane, click the swimlane icon, then enter the name of 
the new swimlane. 
 

What happens if adding a 
swimlane pushes other 
swimlanes beyond the page 
boundary? Do they move to the 
next page? 
 

Do swimlane headers repeat on all 
pages when printing? 

Yes.  
In addition, headers repeat when exporting to Web or Microsoft Office 
applications. The iGrafx Print Preview figure shows headers repeating 
automatically.  
 

 
 

Create a multi-page diagram 
with swimlanes. Change the 
header of a swimlane and see if 
the change is shown on the 
other page. 
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Question iGrafx Response Questions for Challenger  

Can shapes representing activities 
span multiple swimlanes?  

Yes. 
Hold the CTRL key down while growing a shape. Cross-functional activities 
can also be simulated. The iGrafx figure below shows an activity performed 
by two departments only (not the Production department). 
 

 
 

Create a shape that spans 
multiple departments. 
How do you represent 
departments not involved in the 
activity?  

Can a process hierarchy be created in 
a single file? 

Yes. 
iGrafx allows an unlimited number of process maps within a single file. The 
File > Components explorer displays and manages the hierarchy. 
 

 
 

How do you create a file with 
multiple diagrams that each 
span more than one page. 
Can the tool define a process 
hierarchy? 
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Question iGrafx Response Questions for Challenger  

Do link indicators appear 
automatically on all shapes linked to 
sub-processes or supporting 
documents? 

Yes. 
In iGrafx, the standard link indicator symbol is a shaded shape, but other 
link indicators are available. For example, the “chain” symbol shown here: 
 

 

 

Is automatic shape numbering 
available? 

Yes.  
Shape numbers reside in a secure “field” on each shape. Because the 
numbers are located separately from the shape text, they are easier to read 
and modify. 
 
By using a numbering “field”, editing the shape text can’t affect the shape 
number adversely. 
 
iGrafx also supports hierarchical shape numbering. When the number of a 
parent shape changes, all shapes in a linked subprocess are automatically 
renumbered appropriately. 
 

Are shape numbers separate 
from the shape text?  
 
Can all shape numbers be 
easily turned on and off as 
desired?  
 
Does changing a shape 
number have any affect on a 
linked diagram? 

Can shapes be removed from the 
connectivity (“auto-healed”) without 
deleting neighboring connection lines? 
 

Yes.  
iGrafx provides an “auto-healing” feature. This feature reduces the time 
required to build process maps. 
 
Before delete:                                After Delete 

     
 
 

Add three connected shapes 
and delete the middle one. 
What happens? 
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Question iGrafx Response Questions for Challenger  

Are new pages added automatically as 
necessary? 

Yes. 
New pages are added automatically as shapes are dropped outside of 
existing page boundaries. The gray dashed line shows the original page 
boundary: 
 

 
 
Adding additional shapes outside of page one creates a new page: 
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Question iGrafx Response Questions for Challenger  

Are automatic off-page connectors 
available?  

Yes.  
Use the Off-page Connectors tab of the Format > Diagram dialog. This 
feature makes it easier to follow the flow of multi-page diagrams. If the Page 
Setup is changed to print to a single, large plotter page, the off-page 
connectors hide automatically. 
 

 
 

If manual connectors must be 
used, how many steps are 
required to insert them? 
 
How do you convert a multi-
page diagram to print as a 
single page to a plotter?  
 
If the page size grows or 
shrinks, do off-page connectors 
automatically removed or 
created?  
 

Is there a Toolbox Toolbar? Yes. 
Frequently used shapes are available from the frame border. This makes 
common shapes easier to find and reduces the area taken by the user 
interface. Pre-defined templates can pre-set the shapes available. 
 

                                                              

 

The 
iGrafx 
Toolbox 
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Question iGrafx Response Questions for Challenger  

Can business process information 
(e.g. schedules, resource allocation 
levels) be part of the file? 

Yes. 
iGrafx processes are more than just diagrams – they are process models 
that can later be simulated and analyzed providing business process 
improvement. Within each document, multiple scenarios are definable for 
resource allocations, work schedules (see below), transaction rates, costs, 
etc.   

 

 

Is there a Tabular View for easy 
viewing of business process 
information?  

Yes. 
Process data is displayed and edited in both graphical and tabular formats.  
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Is there an Autosensing feature where 
multiple shapes can be easily added 
and edited in a single mode – without 
drag and drop? 

Yes. 
Users add shapes, resize and move items, label objects and draw 
connecting lines with the default iGrafx editing mode. 

 

Are decision shapes intelligent (e.g. 
lines drawn from them automatically 
include “no” and “yes” text)? 

Yes. 
By default, iGrafx decision shapes automatically include connection line 
text. The default “yes” / “no” routing text can be changed if desired.  
 

 
 

 

Can Connection Lines be added to 
any point on the face of a shape? 

Yes.  How many steps are required 
to add additional connection 
points to a shape? 
 

Is there a format gallery? Yes. 
The Gallery provides quick access to frequently used formatting controls 
including Fill, Font, Line, Arrows, and Shadow/3D. 
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Can “Notes” be added to shapes so 
that they “pop-up” when the cursor is 
dragged over the shape? 

Yes.  
To add notes, use the View > Note command with a shape selected. 
Display notes by moving the cursor over any shape with a Note indicator. 
 

 
 

The Challenger tool may allow 
“comments” but comments are 
inferior to Notes: 
 
• Comments are always 

marked with a person’s 
name. 

• Comments can’t be 
formatted. 

• Comments don’t appear 
when published to Web. 

Compare features for defining Cause & 
Effect diagrams. 

The iGrafx Cause & Effect diagram type initializes the workspace with a 
default fishbone diagram, statistical worksheet, optional FMEA sheet, and 
Pareto chart.  
 
These elements are linked together. For example, if a value in a worksheet 
is changed then the associated fishbone diagram and Pareto chart are 
updated automatically. 
  
Six Sigma and quality professionals require an effective Cause & Effect tool. 
 

Does the Challenger tool 
automatically link model data, 
FMEA, fishbone diagram and 
Pareto Chart together?  
 
When lines are lengthened on a 
fishbone diagram, do the 
secondary causes lose their 
horizontal orientation like below: 
 
Before adjusting main cause: 
 

 
After: 
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Can IDEF0 models be created and 
verified compliant to the specification? 

Yes. 
The iGrafx IDEF0® add-on (purchased separately) includes “correct-by-
construction” and “rules-checking” capabilities to ensure that IDEF0 models 
meet all requirements of the IDEF0 specification.  
 

 
 

 

Can multiple models and supporting 
documents be web published with a 
single command? 

Yes. 
For example, publish a directory of 25 iGrafx and Microsoft Office 
documents, modify three of the files, republish and iGrafx automatically 
updates only the three web documents whose source iGrafx files have 
changed.  
 
Use a convenient tree control to customize the publish list. The published 
files also have a tree control for navigating between files. 
 
In addition, iGrafx links between documents become valid URL links after 
publishing to Web format. 
   

Create a diagram with a link to 
a Word document.  
 
Can both the diagram and 
Word document be published to 
Web with a single command? 
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Can diagrams be exported to 
Microsoft Word and PowerPoint in 
paginated format? 

Yes. 
Use the File > Publish As command. Multi-page iGrafx process maps are 
published to separate pages. This is an important feature when publishing 
large process maps. 
 

 

Can diagrams be immediately used for 
process analysis and simulation? 

Yes. 
iGrafx Process™ and iGrafx Process for Six Sigma simulates and analyzes 
any iGrafx process map (including iGrafx FlowCharter files). Go beyond 
simply documenting your existing processes. Analyze and optimize them to 
improve your business and enhance customer satisfaction. 
 

 

Does the vendor provide a central 
repository tool that is integrated with 
the process mapping tool? 

Yes. 
iGrafx Process Central® is a team-based collaborative application that 
delivers version control, link management, document security, audit trail, 
query, and automatic web publishing capabilities.   
 

 

 
 
 
iGrafx, Corel, iGrafx IDEF0, iGrafx FlowCharter, iGrafx Process, and Process Central are registered trademarks or trademarks of Corel, Inc. Microsoft and PowerPoint are registered 
trademarks of Microsoft Corporation. All other products are trademarks of their respective holders. All product specifications or features are subject to change without notice. 
 


